Netscape 7.01 and Mozilla User Agent String Spoof Tip


(06-26-2002 09:18 PM)

A little hint/tip involving Mozilla, custom user agent strings and java.

Since Mozilla went into version 1, if you used a custom user agent string that referenced Internet Explorer and Sun Java version 1.4, the browser will not start. (It tells you that you can't use the Netscape plugin with Internet Explorer).

Why, someone may ask, would you want to do this... to use the Microsoft Knowledge base.

I found that if you set the user agent to:
user_pref("general.useragent.override", "Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2) Gecko/20010726 Netscape6/6.1");

you can get the full functionality of the Microsoft Knowlege base, and have Java installed, even though Mozilla says you cannot. It also solved a few problems with some other sites that had messed up menus with the IE user agent string.

For some reason using a netscape 4.x user agent string does not allow the Microsoft Knowledge Base to display correctly either.

Just throught that I would pass this on as it might come in handy sometime.

Brooks
Tech Support Guy BBS
6/26/02



Back to Top



Return to Netscape Solutions